Questões de Concursos para Professor - Educação Básica

Limpar Busca

var valor: real resultado: real inicio soma <- 0 escreva ("digite um valor") leia (valor) enquanto valor <> 0 faca resultado <- resultado + valor escreva ("digite um valor") leia (valor) fimenquanto escreva ("resultado: ", resultado) fimalgoritmo
Considere que, na lógica do algoritmo apresentado, sejam inseridos sequencialmente os valores a seguir.
3 7 5 0 1 2
Nessa situação, o resultado da execução será

  • A 5.
  • B 18.
  • C 375012.
  • D 15.
  • E 16.

Java é uma linguagem construída a partir de um legado das linguagens C e C++. No entanto, ela apresenta características únicas que a diferem das demais, como:
I o applet, que é um tipo especial de programa Java projetado para ser transmitido pela Internet e executado por um navegador web compatível com Java. II a saída de seu compilador não gera um código executável e, sim, um bytecode. III o fato de um programa Java ser executado somente pela Java virtual machine (JVM).
Assinale a opção correta.

  • A Apenas o item I está certo.
  • B Apenas o item II está certo.
  • C Apenas os itens I e III estão certos.
  • D Apenas os itens II e III estão certos.
  • E Todos os itens estão certos.

De acordo com a Base Nacional Comum Curricular, há que se considerar, ainda, que a cultura digital tem promovido mudanças sociais significativas, nas sociedades contemporâneas. Em decorrência do avanço e da multiplicação das tecnologias de informação e comunicação e do crescente acesso a elas pela maior disponibilidade de computadores, telefones celulares, tablets e afins, os estudantes estão, dinamicamente, inseridos nessa cultura, não somente como consumidores. Os jovens têm se engajado cada vez mais como protagonistas da cultura digital, envolvendo-se, diretamente, em novas formas de interação multimidiática e multimodal e de atuação social em rede, que se realizam de modo cada vez mais ágil. Por sua vez, essa cultura também apresenta forte apelo emocional e induz:

  • A ao aprofundamento da reflexão crítica sobre os conhecimentos dos componentes da área, dada a maior capacidade de abstração dos estudantes. Essa dimensão analítica é vista como meio para a compreensão dos modos de se expressar e de participar no mundo, constituindo práticas mais sistematizadas de formulação de questionamentos, seleção, organização, análise e apresentação de descobertas e conclusões.
  • B ao imediatismo de respostas e à efemeridade das informações, privilegiando análises superficiais e o uso de imagens e formas de expressão mais sintéticas, diferentes dos modos de dizer e argumentar característicos da vida escolar.
  • C a explorar diversas práticas de linguagem em diferentes campos da atividade humana para continuar aprendendo, ampliar suas possibilidades de participação na vida social e colaborar para a construção de uma sociedade mais justa, democrática e inclusiva.
  • D Nenhuma das alternativas.

1. var 2. cont,n,resultado:inteiro 3. inicio 4. resultado <-1 5. leia(n) 6. para cont de 1 ate n passo 1 faca 7. resultado <- resultado *cont 8. fimpara 9. escreva(resultado) 10. fimalgoritmo
Em relação à lógica do algoritmo precedente, caso o valor de n (linha 5) seja igual a

  • A 4, o resultado será 4.
  • B 3, o resultado será 5.
  • C 2, o resultado será 12.
  • D 6, o resultado será 30.
  • E 5, o resultado será 120.

A iniciativa .NET, da Microsoft, apresenta um conjunto totalmente novo de conceitos dessa plataforma. Esse framework possui diversos elementos que a compõem: um deles é o conjunto de tipos de dados comuns, na forma de objetos, os quais podem ser utilizados por todas as linguagens habilitadas ao .NET, como o C#. O elemento do framework .NET citado no texto é

  • A o metadata.
  • B o web services.
  • C a class library.
  • D o common type system.
  • E o common language runtime.